Homepage static page instead of latest post

I changed the homepage to static page in the wordpress configuration but it always returns the latest post, how can i change the homepage to a static page.

1 Like

Nvm, i think i found the solution, the below is working

  {
      "name": "@frontity/wp-source",
      "state": {
        "source": {
          "api": "http://localhost/test1/wp-json",
          "homepage": "/homepage", // seems like this fixed it
        }
      }
    }

Hey @serge.jerkezian glad to see that you were able to solve it :slight_smile:

Btw, what are you building with Frontity? We would love to see it!

I was thinking of migrating a simple wordpress website (http://nine-technology.com/) and play around with the framework…But sadly currently stuck at this issue (API first request always 404) first load is always 404 after I change the api url to my url.

Thanks for sharing your plans :slight_smile:

I’m sure the team will be able to help you this week with your issue :wink:

1 Like

Hi @serge.jerkezian

Check that in this line:

"homepage": "/homepage"

the slug of your homepage is correct.

its working fine now, after i added the “homepage”, thanks

Wouldn’t it be possible to make it so that if a static page is configured in WordPress, this changes automatically for Frontity, instead of that the frontity.settings.js file has to be changed as well?

I’d like it if there was only one location in which this should be changed and preferably that’d be in WordPress, so a client is able to do this without interference of a developer.