Vercel via Github: Cannot find module '@frontity/core'

Hi there,

first time commenting. Apologies if this is a stupid question…

Am attempting to deploy to Vercel via Github. I am running npx frontity serve as the build command, and am getting the error. Should the build framework be “Other”?
Have tried root directory as / and /build. same error for both.
I successfully deployed from Frontity in the terminal directly but with Github I seem to be not getting anywhere.

Frontity seems like a great way to get into React which I have been trying to do for a long time so thanks for the cool framework!

Hi @doubemarvellous

Welcome to the Frontity community. There are no stupid questions. :grinning_face_with_smiling_eyes:

It looks like you’re trying to deploy as a serverless function. If so we have a guide to deploying Frontity as a serverless function coming very soon. It’s currently being worked on.

Hi thanks for the reply! To be honest, I don’t really understand how to move forward here. I followed the docs to deploy to Vercel which initially was successful using npx vercel login etc…, then I couldn’t update the build further without using Git, so I tried to deploy that way with a new project, but ran into the aforementioned error.

Have been trying to deploy again from terminal using npx vercel but getting timeouts. The site is nothing, just a test of Frontity so I know how to deploy somewhere. Aside from this difficulty I really like it.

As I am just trying to deploy my demo site anywhere and update it, how do you recommend? I am not intentionally trying to deploy as a serverless function, just trying to deploy in a basic way anywhere. Tried Netlify which didn’t work as I can see from the community.

Hi so I gave up trying to upload through Git and finally uploaded the project to Vercel using npx vercel…I needed to delete the .vercel folder that had been created in previous attempts. I also got rid of the mars theme, and it built and uploaded