Verce - Internal Server Error

Hi,
after uploading my frontity app to vercel, I see an Interval Server Error when I want to visit it. i have already added the vercel.json file as

{
    "version": 2,
    "builds": [
        {
            "src": "package.json",
            "use": "@frontity/now"
        }
    ]
}

This is the Deployment Status. Any idea?

[15:32:48.292] Retrieving list of deployment files...
[15:32:51.547] Downloading 54 deployment files...
[15:32:53.056] Looking up build cache...
[15:32:53.348] Build Cache not found
[15:32:53.385] Running "vercel build"
[15:32:53.885] Vercel CLI 28.4.7
[15:32:53.900] WARN! Did you mean to deploy the subdirectory "build"? Use `vc --cwd build` instead.
[15:32:54.014] WARN! Due to `builds` existing in your configuration file, the Build and Development Settings defined in your Project Settings will not apply. Learn More: https://vercel.link/unused-build-settings
[15:32:54.025] > Installing Builder: @frontity/now
[15:32:55.880] Downloading user files...
[15:32:55.889] Warning: Detected "engines": { "node": "14.15.0" } in your `package.json` with major.minor.patch, but only major Node.js Version can be selected. Learn More: http://vercel.link/node-version
[15:32:55.903] Installing dependencies...
[15:32:55.903] Detected `package-lock.json` generated by npm 7+...
[15:32:56.957] npm WARN EBADENGINE Unsupported engine {
[15:32:56.958] npm WARN EBADENGINE   package: '[email protected]',
[15:32:56.958] npm WARN EBADENGINE   required: { node: '14.15.0', npm: '7.24.2' },
[15:32:56.958] npm WARN EBADENGINE   current: { node: 'v14.20.0', npm: '8.11.0' }
[15:32:56.958] npm WARN EBADENGINE }
[15:33:02.985] npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated
[15:33:03.763] npm WARN deprecated [email protected]: See https://github.com/lydell/source-map-url#deprecated
[15:33:03.843] npm WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
[15:33:03.868] npm WARN deprecated [email protected]: See https://github.com/lydell/source-map-resolve#deprecated
[15:33:04.138] npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated
[15:33:04.530] npm WARN deprecated [email protected]: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
[15:33:09.656] npm WARN deprecated [email protected]: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
[15:33:14.349] 
[15:33:14.349] added 944 packages in 18s
[15:33:14.350] 
[15:33:14.350] 60 packages are looking for funding
[15:33:14.350]   run `npm fund` for details
[15:33:14.368] Running "build" script in "package.json"
[15:33:14.375] Detected `package-lock.json` generated by npm 7+...
[15:33:14.375] Running "npm run build"
[15:33:14.670] 
[15:33:14.670] > [email protected] build
[15:33:14.670] > frontity build
[15:33:14.670] 
[15:33:16.270] 
[15:33:16.271]   - mode: production
[15:33:16.271]   - target: both
[15:33:16.271]   - public-path: /static/
[15:33:16.271] 
[15:33:16.300] Building es5 bundle
[15:33:32.119] 
[15:33:32.119] asset size limit: The following asset(s) exceed the recommended size limit (488 KiB).
[15:33:32.119] This can impact web performance.
[15:33:32.120] Assets: 
[15:33:32.120]   frontity-react.es5.deaa3729f19cc39b2bad.js (709 KiB)
[15:33:32.120] 
[15:33:32.120] entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (488 KiB). This can impact web performance.
[15:33:32.120] Entrypoints:
[15:33:32.120]   frontity-react (709 KiB)
[15:33:32.120]       frontity-react.es5.deaa3729f19cc39b2bad.js
[15:33:32.120] 
[15:33:32.120] 
[15:33:32.120] webpack performance recommendations: 
[15:33:32.120] You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
[15:33:32.121] For more info visit https://webpack.js.org/guides/code-splitting/
[15:33:32.121] 
[15:33:32.121] Building module bundle
[15:33:42.149] 
[15:33:42.149] asset size limit: The following asset(s) exceed the recommended size limit (488 KiB).
[15:33:42.149] This can impact web performance.
[15:33:42.149] Assets: 
[15:33:42.150]   frontity-react.module.bad4472f03e4212c67ab.js (552 KiB)
[15:33:42.150] 
[15:33:42.150] entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (488 KiB). This can impact web performance.
[15:33:42.150] Entrypoints:
[15:33:42.150]   frontity-react (552 KiB)
[15:33:42.150]       frontity-react.module.bad4472f03e4212c67ab.js
[15:33:42.151] 
[15:33:42.151] 
[15:33:42.151] webpack performance recommendations: 
[15:33:42.151] You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
[15:33:42.151] For more info visit https://webpack.js.org/guides/code-splitting/
[15:33:42.151] 
[15:33:42.152] Building server bundle
[15:33:53.543] 
[15:33:53.681] Finished.
[15:33:53.699] Build Completed in /vercel/output [58s]
[15:33:56.526] Generated build outputs:
[15:33:56.526]  - Static files: 5
[15:33:56.526]  - Serverless Functions: 1
[15:33:56.527]  - Edge Functions: 0
[15:33:56.527] Serverless regions: Washington, D.C., USA
[15:33:56.527] Deployed outputs in 2s
[15:33:57.390] Build completed. Populating build cache...
[15:33:57.590] Uploading build cache [400.71 kB]...
[15:33:58.186] Build cache uploaded: 596.235ms
[15:33:58.201] Done with "."

THANKS

try to remove package-lock.json from your repo and let the server build it’s own

Hi @1600tc ! thanks for your relpy. But doesnt work…

This is the process I have followed:

  1. remove package-lock.json form the project.
  2. npx vercel

And this is the error I receive:

[09:44:21.036] Retrieving list of deployment files...
[09:44:25.085] Downloading 57 deployment files...
[09:44:26.041] Looking up build cache...
[09:44:26.589] Build cache downloaded [400.71 kB]: 227.546ms
[09:44:26.620] Running "vercel build"
[09:44:27.117] Vercel CLI 28.4.7
[09:44:27.127] WARN! Did you mean to deploy the subdirectory "build"? Use `vc --cwd build` instead.
[09:44:27.241] WARN! Due to `builds` existing in your configuration file, the Build and Development Settings defined in your Project Settings will not apply. Learn More: https://vercel.link/unused-build-settings
[09:44:27.310] Downloading user files...
[09:44:27.313] Warning: Detected "engines": { "node": "14.15.0" } in your `package.json` with major.minor.patch, but only major Node.js Version can be selected. Learn More: http://vercel.link/node-version
[09:44:27.317] Installing dependencies...
[09:44:27.673] yarn install v1.22.17
[09:44:27.694] info No lockfile found.
[09:44:27.700] [1/5] Validating package.json...
[09:44:27.703] error [email protected]: The engine "node" is incompatible with this module. Expected version "14.15.0". Got "14.20.0"
[09:44:27.715] error Found incompatible module.
[09:44:27.715] info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
[09:44:27.728] Running "build" script in "package.json"
[09:44:27.729] Running "yarn run build"
[09:44:27.908] yarn run v1.22.17
[09:44:27.933] error [email protected]: The engine "node" is incompatible with this module. Expected version "14.15.0". Got "14.20.0"
[09:44:27.945] error Commands cannot run with an incompatible environment.
[09:44:27.945] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[09:44:27.963] Error: Command "yarn run build" exited with 1

any idea? thanks a lot!

@1600tc now it works!!

After removing the package.lock.json, I have changed in the package.json the engines node version to 14.20.0.

"engines": {
    "node": "14.20.0",
    "npm": "7.24.2"
  },

and now everything works perfectly!
Thaanks for your time !