Rename "name" query to "frontity_name"


Frontity supports multisite.

  • While developing, you can access a specific site using a ?name=XXX query.
  • In production, Frontity chooses the site using the "match" parameter of each site.

But with the upcoming release of the Theme Bridge, we can use the ?name=XXX query to specify a site, without the need for a "match" setting.

For that reason, we should rename the ?name= query to ?frontity_name= and from now on, we should use the namespace ?frontity_xxx for any other option passed by query.

That way, we can remove all those options with a single router converter. Also, we free common query names, like "name", to be used by the apps without problems.


  • /?frontity_name=main-site
  • /some-post/?frontity_name=blog
  • /some-post/?frontity_name=blog-amp

User Stories

As a Frontity Theme Bridge user
I want to configure which site I want to link from my WordPress dashboard
so that I don’t have to configure "match"

As a Frontity developer
I want to use common query names like "name" in my app
so that I can use whatever query name I want.

Possible solution

We can simply change one query for the other. This query is not used in the code, so we don’t need to release it as a major version.