"Oops, something bad happened"

Description of your issue
I learned about Frontity last night and rolled out my website to layer 0 this morning.

There is no problem in the execution results of the following script except the following message ‘entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (488 KiB). This can impact web performance.’.

    "layer0:dev": "layer0 dev",
    "layer0:build": "layer0 build",
    "layer0:deploy": "layer0 deploy",

Specific errors you’re getting in the terminal or in the browser’s console
Oops, something bad happened

A repository with the code of your project

A deployed version of your site

The URL of your WP REST API

Hi @pitang1965 !
For what I could gather, your WP REST API is protected and cannot be accessed by Frontity.
This endpoint, for example, returns 403 Forbidden: https://software.pitang1965.com/wp-json/wp/v2/posts?_embed=true&slug=skill-set

You need to make your REST API public for Frontity to work.

I hope this is of help :slight_smile:

1 Like

Thank you for your comment.
I think everyone has access to https://software.pitang1965.com/wp-json, but is it still protected in this situation?
I don’t even know where to switch protection in WordPress.

I cannot tell where you can change the settings to access the REST API. Since WP 4.7 the REST API is active by default. Maybe you have some plugin/theme blocking it, or the hosting service is doing that. I can see that the /wp-admin page is also restricted at server level, so maybe that helps you troubleshoot.

1 Like

Thank you for your comment.
I tried disabling WordPress security plugins, but the results don’t change.
Is it related to WP GraphQL etc.?

Nop, it shouldn’t be related to GraphQL, as that plugin has its own endpoint. I’d suggest you ask the hosting service if they are blocking it, if you didn’t find any plugin that might be causing it.

EDIT: actually it looks like your GraphQL endpoint is working https://software.pitang1965.com/graphql
EDIT 2: This might have some info for your problem: WordPressセキュリティ設定 | 法人向けレンタルサーバー【Xserverビジネス】サポートサイト

1 Like

Thank you for your comment.
I will ask the hosting service.

After reviewing the settings of the rental server, I found that REST API access from overseas was restricted.
Now the problem is gone.
Thank you very much.

1 Like

I’m glad you made it work :slight_smile:

1 Like