Issues with indexing the site on search engines // Head Tags API returns robots with content="noindex,follow"?

Hello Frontity team,

I just noticed that the site can not be indexed by google due to the <meta data-rh="true" name="robots" content="noindex,follow">which is coming from Head Tags API.

image

So, google can’t index the site:

Also don’t see any blocking setup in WordPress.

image

Repository: https://github.com/dejangeorgiev/ruthgeorgiev-frontity
URL: https://ruthgeorgiev.com/

Will be grateful for any help / advice.

Thank you.
Best,
Dejan

Hi @dejangeorgiev

Do you have a SEO plugin such as Yoast or All-in-one-SEO installed? If so how is it configured generally? How is it configured for individual pages/posts?

I notice that this issue isn’t site-wide. For example, for the page https://ruthgeorgiev.com/category/vegetarian/ you have this:

<meta data-rh="true" name="robots" content="all">

For the page https://ruthgeorgiev.com/dishes/vegetable-sides/ you have this:

<meta data-rh="true" name="robots" content="index, follow">

But for the home-page as you’ve observed you have:

<meta data-rh="true" name="robots" content="noindex,follow">

So the meta robots instruction varies depending on which page you land on. If you have a SEO plugin please check the settings for each page. The head-tags plugin is zero-config apart from state.frontity.url and state.source.api in frontity.settings.js which are already set correctly according the repo that you provided.

Oh, one more thing I just noticed, in the repo in frontity.settings.js the state.source.api is set to:

https://admin.ruthgeorgiev.com/wp-json

whereas the state.frontity.url is set to:

https://ruthgeorgiev.com

i.e. without the admin. I’m guessing that state.source.api shouldn’t have admin in it.