Issue with isArchive after changing category base

Hello friends,

I’ve switched the Category base in Wordpress > Settings > Permalinks to “Topics”.

On the Frontity side, I see that when I look at the we’re seeing an entry for "/topics/insights/’, which was previously the default "/category/insights/’ before switching the category base.

However, if I navigate to “/topics/insights/” in the browser, then I get a 404. This was not the case before switching the category base. “/category/insights/” worked just fine - no 404.

data.isArchive no longer is true for “/topics/insights/”, whereas it was true for “/category/insights/” before the category base was changed.

Any ideas on why this might be happening would be greatly appreciated, thank you!

Hey Brett,

That means that the handler is not detecting the url so its not adding isArchive to the data of the link.

From what I can see you also have to adjust that in frontity.

Have you done that already?

1 Like

Thanks so much, that was the solution. Still becoming familiar with the docs, I must have missed that.

Take care!

1 Like

Glad it worked, man!

1 Like