Getting error while running " npx frontity dev"

Hi Team,

I have tried the framework and it’s working fine.

But I am facing some issue while running the command " npx frontity dev"

detailed question.

When I setup the demo as stated in get started guide and run the command " npx frontity dev" it’s working fine but when I stop the server and try to run the command " npx frontity dev" again it gives me below error:
Error: listen EADDRINUSE :::3000
at Object._errnoException (util.js:1022:11)
at _exceptionWithHostPort (util.js:1044:20)
at Server.setupListenHandle [as _listen2] (net.js:1367:14)
at listenInCluster (net.js:1408:12)
at Server.listen (net.js:1492:7)
at start (/home/md0122-janak/my-app/node_modules/@frontity/core/dist/scripts/utils/create-app.js:19:20)
at compiler.compilers.(anonymous function).hooks.done.tapAsync (/home/md0122-janak/my-app/node_modules/@frontity/core/dist/scripts/utils/create-app.js:28:13)
at _next0 (eval at create (/home/md0122-janak/my-app/node_modules/tapable/lib/HookCodeFactory.js:33:10), :26:1)
at _err0 (eval at create (/home/md0122-janak/my-app/node_modules/tapable/lib/HookCodeFactory.js:33:10), :41:1)
at Immediate. (/home/md0122-janak/my-app/node_modules/webpack-bundle-analyzer/lib/BundleAnalyzerPlugin.js:77:13)

So, next if I want to work with the project I have to reboot my system and then I can work.

For the information, I am using the Ubuntu system.

Let, me know if you need more details on this.


1 Like

Hi @janak.kaneriya!

It seems that the error is about http://localhost:3000 being busy with another service. I don’t know if it’s another service you have running on that port or for some reason the process of the previous npx frontity dev is still running, but we haven’t noticed anything like that on Ubuntu.

You can always use the --port option to run the server on another port, e.g.:

npx frontity dev --port 4000

Let us know if that works for you! :slight_smile:

Hello @orbalo,

Thank you for your reply.

However, your suggestion works fine.

I am sure when we run “npx frontity dev” again on the same port it will not work.

So, I think there should be something to restart the server so we can start the server on same port.

Let, me know if you want to know more.


How are you shutting down the server? Are you using Ctrl+C in the terminal? Closing the terminal window directly? Are you using VSCode terminal?

No worries!!!

Before I was closing by ctrl+z which I think causing some problems but when trying with Ctrl+c I can restart the server again.

Appreciated your quick responses.


1 Like

Oh, great. I’m glad that is solved now! :smile:

Feel free to open more topics if you find any other problem or doubt.