Error deploying to hosting

My build look like this:


When i deploy build to hosting i get this error

Forbidden

You don’t have permission to access this resource.

I think there can be some problem with build

You should upload the source files to the server and run the build command on the server itself, instead of uploading the build files to the server.

And you should make sure you have enough permissions to build and run the required commands on the server.

i upload my project to the hosting, and do npm install and npm run build, but problem is still here.
Can You please write steb-by-step guide?
this is what my project looks like on hosting

npx frontity build
npx frontity serve

and when all settings are correct (and the server is setup properly) you should be able to access Frontity.

If you can give a bit more information about the project, like access to the source code on GitHub for example, that would help us helping you.

its still doesnt work, so send you link to clone code
git clone Bitbucket

Should i have .htaccess file, maybe problem because i doesnt have him?

I checked the repo and see a lot of stuff missing, especially in frontity.settings.js.

What happens if you run npx frontity dev or npx frontity build | npx frontity serve locally (on your local PC), does it return any errors and can you access the project?

On local PC everything working good, which staff is missing? I’m tried add . htaccess with redirect from every URL to 127.0.0.1:3000 and main page starts work but it’s don’t see images from build

See 2. Settings - Frontity Docs, because you’re missing the info about your site itself.

So you can access Frontity, but can’t access the assets (JS, images, stylesheets, etc.)?

.htaccess won’t help you, unless you use Apache as a proxy and have the /static/ folder setup correctly in the .conf file of Apache.

Again; more info about the project, the server setup, what is working and what not, etc will help us a lot. Because right now we just guess on what it might be, even when you already tried it or is completely irrelevant in your situation.



can its be problem with WordPress? On localhost everething working good, but on hosting its give 503

A 503 error is obviously a server related error, and it means the server doesn’t exist or isn’t running correctly (wrong config).

Hi @shevabogdan16

Where are you uploading your project to? i.e. what hosting service are you using? Try following this guide to upload your project to Vercel. Does it work there?

Ok, i’ve found answer, that was problem with permalinks. Thank you.

1 Like

Hi @shevabogdan16

Please post your solution so that other community members can benefit. Thanks.