Deploying project to vercel

I’ve tried to deploy my project using GitHub but also in the terminal using npx vercel. I’m getting the following error.

This is my source code:

09:41:09 Analyzing source code…
09:41:09 Warning: Due to builds existing in your configuration file, the Build and Development Settings defined in your Project Settings will not apply. Learn More: https://vercel.link/unused-build-settings
09:41:10 Installing build runtime…
09:41:13 Build runtime installed: 2284.548ms
09:41:26 Looking up build cache…
09:41:27 Build cache not found
09:41:28 Downloading user files…
09:41:48 npm WARN read-shrinkwrap This version of npm is compatible with [email protected], but package-lock.json was generated for [email protected] I’ll try to do my best with it!
09:42:07 npm ERR! code EEXIST
09:42:07 npm ERR! path /vercel/workpath0/node_modules/.bin/ts-script
09:42:07 npm ERR! Refusing to delete /vercel/workpath0/node_modules/.bin/ts-script: is outside /vercel/workpath0/node_modules/ts-node and not a link
09:42:07 npm ERR! File exists: /vercel/workpath0/node_modules/.bin/ts-script
09:42:07 npm ERR! Remove the existing file and try again, or run npm
09:42:07 npm ERR! with --force to overwrite files recklessly.
09:42:07 npm ERR! A complete log of this run can be found in:
09:42:07 npm ERR! /vercel/.npm/_logs/2021-03-15T08_42_07_130Z-debug.log
09:42:07 Error: Command npm install exited with 1
09:42:11 Done with package.json

I’ve been able to deploy the project previously without issue:
https://portfolio-chi-sand.vercel.app/

I think the issue is with trying to deploy the Chakra theme as a local package instead of as a node module.

Best,
Erik

Looks like I messed up the install somehow, reinstalling with npx frontity create --theme frontity-chakra-theme and then overwriting the base theme and frontity-settings files solved the issue.