Changing the package name causes internal server error

So I saw the new chakara-theme and it looked cool, so i installed it with npm and copies the folder it created from the node_modules folder to the local packages folder and changed the frontity.settings.js from "name": "@frontity/mars-theme" to "name": "frontity-chakra-theme".

And it gives me an internal server error. I also have the source pointing to my own wordpress blog and it all works fine when i use the mars package. Any help would be appreciated. I am still new to node

Hello @lexmas, welcome to Frontity.

Using a theme’s default components and designs does not require you to copy the file from node_modules except you want to customize some major parts of the theme. To use a theme like Chakra with its default components and component designs, you need to install via npm by running:

npm install frontity-chakra-theme

After that, you need to add the frontity-chakra-theme to your packages array in the frontity.settings.js file. That is, changing the present theme to the frontity-chakra-theme. Then, configure your frontity.settings.js file as shown is the readme file for the frontity-chakra-147765 .

To make major changes like changing layouts, updating complex designs e.t.c, you’ll have to copy the npm package and paste in a packages folder in the root folder of your Frontity application and also update the directory to the package in your package.json file.

Your package.json should look like this:

  “dependencies”: {
     “frontity-chakra-theme”: “file:./packages/frontity-chakra-theme”

You’ll also need to the npm install command inside the packages/frontity-chakra-theme folder to install the themes dependencies

1 Like

thank you! I got it to work with the demo wordpress blog and i think the issue was because my source wp blog only had one post. might be the same issue these people were having


BTW, we have released a guide about this in our docs: :slight_smile: