Can't run site locally after deploying to vercel

Hoping someone can shed some light on what’s going on. Yesterday I deployed my site to vercel following the instructions here Deploy Frontity using Vercel - Frontity Docs

Everything worked correctly but I had to update node.js to complete the process.

The site is live on the url (it’s a work in progress) but now I can’t run the site locally using npx frontity dev. I get the following messages on terminal…

Does anyone have any idea why I can’t run the site locally now?

SERVER STARTED -- Listening @ http://localhost:3000
  - mode: development
  - target: module
  - public-path: /static/

(node:30257) Warning: Closing file descriptor 20 on garbage collection
(Use `node --trace-warnings ...` to show where the warning was created)
(node:30257) [DEP0137] DeprecationWarning: Closing a FileHandle object on garbage collection is deprecated. Please close FileHandle objects explicitly using FileHandle.prototype.close(). In the future, an error will be thrown if a file descriptor is closed during garbage collection.
Error: error:0308010C:digital envelope routines::unsupported
    at new Hash (node:internal/crypto/hash:67:19)
    at Object.createHash (node:crypto:130:10)
    at module.exports (/home/russell/sites/
    at NormalModule._initBuildHash (/home/russell/sites/
    at handleParseError (/home/russell/sites/
    at /home/russell/sites/
    at /home/russell/sites/
    at /home/russell/sites/
    at iterateNormalLoaders (/home/russell/sites/
    at iterateNormalLoaders (/home/russell/sites/`

Does anyone have any thoughts on this? I’m struggling to get my site finished because I can’t run it locally since deploying it.

Ok so i’ve tried downgrading my version of node.js on my laptop but I can’t seem to get this to work either.

Does anyone have any tips on where I can start to figure this out? Currently I can’t edit my site at all.

Please can someone help?

Hello Russel,

You can try this: Detect "node-modules" under "packages" folder, remove them and launch reinstall from root - #2 by SantosGuillamot

It has worked for me in the past. Good luck.

Thanks @maurice.tadros In the end i had to powerwash my chromebook but now i’m having an issue getting the repository from GitHub!

Try this. Detect "node-modules" under "packages" folder, remove them and launch reinstall from root

1 Like

Thanks for the tip. Will definitely try this if it happens again.