Cannot Deploy to Vercel


Having trouble deploying to Vercel.

Here’s the log:

Here’s my package.json:

  "name": "oddboll",
  "version": "1.0.0",
  "private": true,
  "description": "Frontity project",
  "keywords": [
  "engines": {
    "node": ">=10.0.0",
    "npm": ">=6.0.0"
  "scripts": {
    "dev": "frontity dev",
    "build": "frontity build",
    "serve": "frontity serve"
  "prettier": {},
  "dependencies": {
    "@frontity/core": "^1.16.0",
    "@frontity/html2react": "^1.7.0",
    "@frontity/mars-theme": "./packages/mars-theme",
    "@frontity/tiny-router": "^1.4.4",
    "@frontity/wp-source": "^1.11.7",
    "dayjs": "^1.11.9",
    "frontity": "^1.17.2",
    "oddboll": "file:packages/oddboll"

I tried this solution but it did not help. I also tried changing node version to 16.x both inside package.json and in Vercel settings but that gave me Error: Found "engines" in "package.json" with an invalid Node.js version range: "16.x". Please set "engines": { "node": "12.x" } in your "package.json" file to upgrade to Node.js 12.

1 Like

UPD: tried using Heroku and deployment fails with the same error.

ended up changing the build inside package.json to "NODE_OPTIONS=--openssl-legacy-provider frontity build" and it worked.

1 Like

Just commenting that this works but not ideal.

1 Like