Can not deploy on Vercel

I am having trouble deploying a Frontity project to Vercel. Every time I try to deploy, I get an error message that says “isModuleDeclaration has been deprecated, please migrate to isImportOrExportDeclaration”. After some investigation, I discovered that this error is related to the @babel/types package, which Frontity core depends on.

To try and resolve this issue, I created a fresh Frontity project and added a version.json file with some basic information. Then, I logged in with npx login and deployed the project to Vercel using npx vercel. However, the deployment still failed with the same error message.

I am seeking help from the community to figure out how to resolve this issue and successfully deploy my Frontity project to Vercel. Any advice or suggestions would be greatly appreciated.

could you please help? its look like problem on core frontity

Which version of node are you using? You have to make sure you are on 14.x as anything newer wont work. Just an assumption what it could be. I have not seen this error before.

@ni.bonev Thanks for your reply I switched to node version 14. X but it does not work.
Same error as the above screenshot

Okey, are you sure the vercel version is also changed. Can you update your build script in package.json to look like this: "build": "node -v && frontity build && node -v",. Then try to deploy and check the logs.

Can you please show me your package.json. I have many projects hosted on vercel and there are no issues with deploying them.

Issue Fixed, it was a node js version issue, I changed it to 14X and started working


Now I am facing the same issue. First I got this issue

and after resolving that now I am getting this issue