I’ve reviewed the PR that @luisherranz has made:
I think it looks great, I have only noticed one thing that I think we should all agree on.
In TSDocs or in Documentation, when describing a method, I think we should be adding the
() after the method name. Right now, we write it like (examples from current TSDocs):
An object that will be used in each call to the REST API when using
actions.source.fetch with the default handlers.
Usually returned from
api.get, but can also be the one returned by
Especially in the second example, it might not be clear to a new user that
fetch are both methods and not some kind of getter or flag.