404s after changing source URL

I moved the back end’s hosting to the client’s domain and server today, which includes a new SSL certificate. I also updated the entire Frontity project to the latest versions because of an error by a new package I am using. Now, I am no longer able to retrieve data from the WordPress website into Frontity. I get the following error from what appears to be a valid route:

  "isError": true,
  "isReady": true,
  "isFetching": false,
  "is404": true,
  "errorStatus": 404,
  "errorStatusText": "You have tried to access content at route: /collections/ but it does not exist",
  "route": "/collections/",
  "link": "/collections/",
  "query": {},
  "page": 1

First thing I changed was to change the source URL to https://wpadmin.pardowoodwork.com and you can see that the site is up at Collections - Pardo and that the REST API is working at https://wpadmin.pardowoodwork.com/wp-json/wp/v2/pages. I have sort of been working in Frontity off-and-on for the last couple months so let me know if there is a glaring error there but it looks good to me. Permalinks are set to use the slug/post title.

Then I had some trouble with the colors package so I decided to run rm -rf node_modules && rm -rf package-lock.json && rm -rf yarn-error.log && rm -rf yarn.lock && npm cache clean --force and then npm install as has worked for me in the past to clean up issues with dependencies (this time with color). After doing so, Frontity updated to the latest version along with a couple other packages, so I’m not sure if those changes broke my project. In the end, due to the issue here, I decided to uninstall the frontity-contact-form-7 package until I get this site back up and running.

Here is the repository’s frontity branch and it should be publicly viewable. Please offer any suggestions as I’m willing to try anything to get this back up and running. I just can’t see where my configuration is wrong on either front end or back end.

Hi David

As you’ve updated Frontity the issue you’re encountering might be related to this one.

There’s a bug fix in progress, you can follow this PR to keep updated.